动态规划 机器人军团 POJ2533 中等

Description

A numeric sequence of ai is ordered if a1 < a2 < … <aN. Let the subsequence of the given numeric sequence (a1,a2, …,aN) be any sequence (ai1,ai2, …,aiK), where 1 <=i1 < i2 < … <iK <=N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8

Sample Output

4
解题思路:
代码:

#include<iostream>
#include<stdio.h>
#include<cstdlib>
using namespace std;
int n,longest;
int a[10001],dp[10001];
int main()
{
	cin>>n;
	longest=1;
	for(int i=1;i<=n;i++)
	{
		cin>>a[i];
		dp[i]=1;
	}
	for(int i=2;i<=n;i++)
	{
		for(int j=1;j<i;j++)
		if(a[i]>a[j])
		dp[i]=max(dp[j]+1,dp[i]);
		longest=max(dp[i],longest);
	}
	cout<<longest<<endl;
	return 0;
}

PS:本博客属于中国石油大学胜利学院ACM协会所有!
BY:李雅琪

猜你喜欢

转载自blog.csdn.net/weixin_43805821/article/details/84927156
今日推荐