HDU3631(Shortest Path)

Shortest Path

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4637    Accepted Submission(s): 1105


Problem Description
When YY was a boy and LMY was a girl, they trained for NOI (National Olympiad in Informatics) in GD team. One day, GD team’s coach, Prof. GUO asked them to solve the following shortest-path problem.
There is a weighted directed multigraph G. And there are following two operations for the weighted directed multigraph:
(1) Mark a vertex in the graph.
(2) Find the shortest-path between two vertices only through marked vertices.
For it was the first time that LMY faced such a problem, she was very nervous. At this moment, YY decided to help LMY to analyze the shortest-path problem. With the help of YY, LMY solved the problem at once, admiring YY very much. Since then, when LMY meets problems, she always calls YY to analyze the problems for her. Of course, YY is very glad to help LMY. Finally, it is known to us all, YY and LMY become programming lovers.
Could you also solve the shortest-path problem?
 

Input
The input consists of multiple test cases. For each test case, the first line contains three integers N, M and Q, where N is the number of vertices in the given graph, N≤300; M is the number of arcs, M≤100000; and Q is the number of operations, Q ≤100000. All vertices are number as 0, 1, 2, … , N - 1, respectively. Initially all vertices are unmarked. Each of the next M lines describes an arc by three integers (x, y, c): initial vertex (x), terminal vertex (y), and the weight of the arc (c). (c > 0) Then each of the next Q lines describes an operation, where operation “0 x” represents that vertex x is marked, and operation “1 x y” finds the length of shortest-path between x and y only through marked vertices. There is a blank line between two consecutive test cases.
End of input is indicated by a line containing N = M = Q = 0.
 

Output
Start each test case with "Case #:" on a single line, where # is the case number starting from 1.
For operation “0 x”, if vertex x has been marked, output “ERROR! At point x”.
For operation “1 x y”, if vertex x or vertex y isn’t marked, output “ERROR! At path x to y”; if y isn’t reachable from x through marked vertices, output “No such path”; otherwise output the length of the shortest-path. The format is showed as sample output.
There is a blank line between two consecutive test cases.
 

Sample Input
 
  
5 10 10 1 2 6335 0 4 5725 3 3 6963 4 0 8146 1 2 9962 1 0 1943 2 1 2392 4 2 154 2 2 7422 1 3 9896 0 1 0 3 0 2 0 4 0 4 0 1 1 3 3 1 1 1 0 3 0 4 0 0 0
 

Sample Output
 
  
Case 1: ERROR! At point 4 ERROR! At point 1 0 0 ERROR! At point 3 ERROR! At point 4
 题意:
给定一些边和权重,求最短路。然而要先mark可访问的结点,之后才可以访问该点。
“0 x”操作,如果顶点x标记,输出”ERROR! At point x”。
操作“1 x y”,如果顶点x或y顶点未被标记,输出”ERROR! At path x to y”;如果y不是可以从x到顶点,输出”No such path”,否则输出路径的长度。

思路:N<=300,且查询任意两点,果断floyd算法求最短路。由于题目限制,注意要标记一个点,对这个点来一次floyd。


#include<cstdio>
#include<cstring>
#define INF 1<<29
#define min(a,b) (a)<(b)?(a):(b)
int dp[305][305],mark[305];
int main(){
	int n,m,q,tc=0;
	while(scanf("%d%d%d",&n,&m,&q)){
		memset(mark,0,sizeof(mark));
		if(n==0&&m==0&&q==0)break;
		if(tc)printf("\n");
		int a, b,c;
		for(int i = 0; i < n; i++){
			dp[i][i]=0;
			for(int j = 0; j < n; j++)
				if(i!=j)
				dp[i][j]=INF;
		}
		for(int i = 0; i < m; i++){
			scanf("%d%d%d",&a,&b,&c);
			dp[a][b]=min(dp[a][b],c);
		}
		printf("Case %d:\n",++tc);
		for(int i = 0;i < q; i++){
			int a,b,order;
			scanf("%d",&order);
			if(order==0){
				scanf("%d",&a);
				if(!mark[a]){
					mark[a]=1;
					for(int i = 0; i < n; i++){
						if(dp[i][a]!=INF)
						for(int j = 0; j < n; j++){
							if(dp[a][j]!=INF)
							dp[i][j]=min(dp[i][j],dp[i][a]+dp[a][j]);
						}
					}
				}
				else
					printf("ERROR! At point %d\n",a);
			}
			else if(order==1){
				scanf("%d%d",&a,&b);
				if(!mark[a]||!mark[b]){
					printf("ERROR! At path %d to %d\n",a,b);
				}
				else if(dp[a][b]==INF){
					printf("No such path\n");
				}
				else
					printf("%d\n",dp[a][b]);
			}
		}
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Mad_boys/article/details/47982993