GZHU18级第一次周赛 D - Problem D

ime limit :1000 ms
Memory limit :32768 kB
OS :Windows
Source :2005实验班短学期考试
问题描述:

给定三条边,请你判断一下能不能组成一个三角形。
Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
Sample Input
2
1 2 3
2 2 2
Sample Output
NO
YES

#include <iostream>
using namespace std;
int main()
{int M, i = 0;
	double a, b, c;
	cin >> M;
	for (i = 0; i < M; i++)
	{
		cin >> a >> b >> c;
		if(a+b>c&&a+c>b&&b+c>a)
			cout << "YES" << endl;
			else cout << "NO" << endl;
	}return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43981590/article/details/84946678