POJ3259 Wormholes(bellman模板&检测负权回路)

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:每组数据先给出m条正权边再给出w条负权边,其中正权边是双向的而负权边是单向的,判断是否存在负权回路。

解题思路:Bellman-Ford解决负权边。

其原理是:对于n个点的图来说,最多只能进行n-1轮松弛就能找到最短路径,如果在进行n-1轮松弛后仍能继续成功松弛,那么此图必然存在负权回路。

Bellman-Ford算法经常会在未达到n-1轮松弛前就已经计算出最短路。所以添加check用来标记数组dis在本轮松弛中是否发生了变化,如果没有发生变化说明松弛结束,提前跳出循环。


AC代码:

#include<stdio.h>
#define INF 0x3f3f3f3f

int dis[510],n,m,w;

struct edge
{
	int s,e,t;
} e[2710];

void bellman()
{
	int flag,check;
	for(int i=1;i<=n;i++)
		dis[i]=INF;
	for(int k=1;k<=n-1;k++)
	{
		check=0;
		for(int i=1;i<=m;i++)//双向路
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
			if(dis[e[i].e]+e[i].t<dis[e[i].s])
			{
				dis[e[i].s]=dis[e[i].e]+e[i].t;
				check=1;
			}
		}
		for(int i=m+1;i<=m+w;i++)//单向路 
		{
			if(dis[e[i].s]+e[i].t<dis[e[i].e])
			{
				dis[e[i].e]=dis[e[i].s]+e[i].t;
				check=1;
			}
		}
		if(check==0) break;
	}
	flag=0;
	for(int i=1;i<=m;i++)//判断是否存在负权回路 
	{
		if(dis[e[i].s]+e[i].t<dis[e[i].e]) flag=1;
	}
	if(flag) printf("YES\n");
	else printf("NO\n");
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d%d",&n,&m,&w);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
		}
		for(int i=m+1;i<=m+w;i++)
		{
			scanf("%d%d%d",&e[i].s,&e[i].e,&e[i].t);
			e[i].t=-e[i].t;//转换为负数表示负权
		}
		bellman();
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/UncleJokerly/article/details/80046706
今日推荐