hdoj 1029 Ignatius and the Princess IV

Ignatius and the Princess IV

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 40625    Accepted Submission(s): 17725


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
 
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
 
  
3 5 1
 
刚开始就以为是一个常规思路题,只要计算出每一个数字的个数,然后将个数排序,如果最多的那个数字数目大于(N+1)/2,则输出对应的数字,我也不知道哪错了,看了别人的博客觉得这其实就是一个思维题,如果数字的数目大于(N+1)/2其实也就是说将数字按照从小到大排序的话,(N+1)/2的位置上一定是要求的数字
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num[1000005];
int main(){
	//freopen("test.in","r",stdin);
	int N;
	while(scanf("%d",&N)!=EOF){
		memset(num,0,sizeof(num));
		for(int i=1;i<=N;i++){
			scanf("%d",&num[i]);
		}
		sort(num+1,num+1+N);
		printf("%d\n",num[(N+1)/2]);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/Dear_Jia/article/details/80047382