QDU-GZS and String

Description

GZS has two strings s and t.

In each step, GZS can select arbitrary character c of s and insert any character d (d ≠ c) just after it.

GZS wants to convert s to t. But is it possible?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case there are two strings s and t, one per line. 1 ≤ T ≤ 10^5 1 ≤ |s| ≤ |t| ≤ 10^5 All strings consist only of lowercase English letters. The size of each input file will be less than 5MB.

Output

For each test case, output "Yes" if GZS can convert s to t, otherwise output "No".

Sample Input 1 

4
a
b
cat
cats
do
do
apple
aapple

Sample Output 1

No
Yes
Yes
No

题意:一开始读错题了,以为只能插一个,是可以插很多个,每个要满足插入的规则就可以了

思路:看长串中是否包含短串的所有字符,如果都有再判断前面有多少个相同的,如果短串的大于等于长串的,并且首字符一定要相同,就可以,否则就不可以,否则就说明插了重的

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#define MAX  100005
using namespace std;

char s1[MAX],s2[MAX];
int main() {

	int T;
	cin>>T;
	for(int t=0; t<T; t++) {
		scanf("%s",s1);
		scanf("%s",s2);
		int i;
		i=0;
		int len1=strlen(s1);
		int len2=strlen(s2);
		for(int j=0; i<len1&&j<len2; j++) {
			if(s1[i]==s2[j]) {
				i++;
			}
		}
		if(i!=len1) {
			printf("No\n");
		} else {
			int sum1=0,sum2=0;
			for(int j=1; j<len1; j++) {
				if(s1[j]==s1[j-1]) {
					sum1++;
				} else {
					break;
				}


			}
			for(int j=1; j<len2; j++) {
				if(s2[j]==s2[j-1]) {
					sum2++;
				} else {
					break;
				}
			}

			if(s1[0]==s2[0]&&sum1>=sum2) {
				printf("Yes\n");
			} else {
				printf("No\n");
			}

		}

	}

	return 0;
}

也可以参考大佬的思路及代码

链接:

https://blog.csdn.net/qq_42936517/article/details/85886959

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/85913752