hdu1556 Color the ball (树状数组应用类型二) 【区间更新 单点求值】

版权声明:限于博主能力有限,不排除出现错误的地方,希望大佬指出,多多 交流,共同进步。 https://blog.csdn.net/SunPeishuai/article/details/85396256

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=1556

Problem Description

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?

 

Input

每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。

 

Output

每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。

 

Sample Input

 

3 1 1 2 2 3 3 3 1 1 1 2 1 3 0

 

Sample Output

 

1 1 1 3 2 1

分析:(参考大佬博客 https://blog.csdn.net/yexiaohhjk/article/details/51077545

树状数组不仅可以求单点更新区间求和,还可以求区间更新,单点求和。 
在单点更新里面,树状数组求和操作代表区间的和,而在区间更新中,树状数组求和操作代表单个元素的变化量。

所以这题比如对(4,6)区间进行更新,就是update(4,1),update(6+1,-1), 
Query(i)代表查询第i个数变化量。

代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int N=100008;
int c[N];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int y)
{
    for(;x<=N;x+=lowbit(x))
    {
        c[x]+=y;
    }
}
int sum(int x)
{
    int ans=0;

    for(;x;x-=lowbit(x))
    {
        ans+=c[x];
    }
    return ans;
}
int main()
{
    int n;
  while(~scanf("%d",&n)&&n)
  {
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
          int a,b;
          scanf("%d%d",&a,&b);
          update(a,1);
          update(b+1,-1);
      }
      for(int i=1;i<=n-1;i++)
      {
          printf("%d ",sum(i));
      }
      printf("%d\n",sum(n));
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/SunPeishuai/article/details/85396256