C - Bridging signals

 C - Bridging signals

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

思路 :

使用最长递增子序列LIS 进行求解

1.使用动态规划

时间复杂度为 0(n^2) 超时

思路:

1.用 dp[i] 表示以 arr[i] 这个数结尾的情况下,arr[0,,,i-1]中的最大递增序列长度。

2.计算dp[i],如果最长递增子序列以arr[i] 结尾,那么arr[0,,,,i-1] 中所有比arr[i]小的数都可以作为倒数第二个数,所以有:

dp[i] = max\left \{ dp[j]+1 \right \}\left ( 0<=j<i,arr[j]<arr[i] \right )

如果 arr[0,,,i-1]中所有的数都比arr[i]小,定dp[i]=1

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAXN = 40010;

int dp[MAXN];

int array[MAXN];
int main(){

    int SeN;

    scanf("%d",&SeN);
    fill(dp,dp+MAXN,1);

    int P;

    for(int i=0;i<SeN;i++){
        scanf("%d",&P);

        for(int j=0;j<P;j++){
            int right;
            scanf("%d",&right);
            array[j] = right;
        }

        for(int k=0;k<P;k++){
            for(int l=0;l<k;l++){
                if((dp[l]+1)>dp[k]&&(array[k]>array[l])){
                    dp[k] = dp[l]+1;
                }
            }
        }

        int max=0;
        for(int k=0;k<P;k++){

            if(max<dp[k]){
                max = dp[k];
            }
        }

        printf("%d\n",max);
        fill(dp,dp+MAXN,1);
    }

    return 0;
}

2.使用结合贪心算法求解:

算法通过 时间复杂度为O(nlogn)

思路:https://blog.csdn.net/coolwriter/article/details/79916458

lower_bound :https://blog.csdn.net/qq_40160605/article/details/80150252

算法步骤:

1.开一个数组B[],所有元素置INF

2.从做到右扫描 arr ,在 B中寻找第一个不小于arr[i]的位置p(也就是在B中寻找第一个大于等于arr[i]的位置p,实际上就是在遍历arr[] 的时候,逐个的将每个值放入B中,使得B是一个递增的序列),将B[p]替换为arr[i].

3.最后B中非INF 的元素个数就是最长递增子序列的长度。

其中 B序列中 非INF 的值的意义就是,在对应长度的子序列中,最小的末尾值为多少。

#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAXN = 40010;
const int INF = 0x3f3f3f3f;
//int dp[MAXN];

int B[MAXN];
int array[MAXN];
int main(){

    int SeN;

    scanf("%d",&SeN);

    int P;

    for(int i=0;i<SeN;i++){
        scanf("%d",&P);

        for(int j=0;j<P;j++){
            int right;
            scanf("%d",&right);
            array[j] = right;
            B[j] = INF;
        }

        for(int j=0;j<P;j++){
            *lower_bound(B,B+P,array[j]) = array[j];
        }

        printf("%d\n",lower_bound(B,B+P,INF)-B);

    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Willen_/article/details/85242653