AMAZING AUCTION(简单模拟)

AMAZING AUCTION

时间限制: 3000 ms  |  内存限制: 65535 KB
难度:4
描述

Recently the auction house hasintroduced a new type of auction, the lowest price auction. In this new system,people compete for the lowest bid price, as opposed to what they did in the past.What an amazing thing! Now you could buy cool stuff with one penny. Your taskis to write the software to automate this auction system. 

First the auctioneer puts an upper limiton bid price for each item. Only positive price less than or equal to thisprice limit is a valid bid. For example, if the price limit is 100, then 1 to100, inclusive, are all valid bid prices. Bidder can not put more than one bidfor the same price on a same item. However they can put many bids on a sameitem, as long as the prices are different. 

After all bids are set, the auctioneerchooses the winner according to the following rules:

(1). If any valid price comes from onlyone bidder, the price is a "unique bid". If there are unique bids,then the unique bid with the lowest price wins. This price is the winning priceand the only bidder is the winning bidder.

(2). If there are no unique bids, thenthe price with fewest bids is the winning bid. If there are more than one pricewhich has the same lowest bid count, choose the lowest one. This price is thewinning price. The bidder who puts this bid first is the winning bidder. 

Giventhe price limit and all the bids that happen in order, you will determine thewinning bidder and the winning price. 

输入
There are multi test cases.EOF will terminate the input.
The first line contains two integers: U (1 <= U <= 1000), the price upper limit and M (1 <= M <= 100), the total number of bids. M lines follow, each of which presents a single bid. The bid contains the bidder's name (consecutive non-whitespace characters<=5) and the price P (1 <= P <= U), separated with a single space. All bids in the input are guaranteed to be valid ones.
输出
Print the sentence "The winner is W" on the first line, and "The price is P" on the second.
样例输入
30 7 
 Mary 10 
 Mary 20
Mary 30
Bob 10
Bob 30
Carl 30
Alice 23
样例输出
The winner is Mary
The price is 20


题意:

模拟一个拍卖活动,要求你找到拍卖赢家,买家可以对一个物品出多次价格但不能相同,你需要判断的赢家,赢家有两种判断方式

如果有唯一的竞猜价格,找到最小的价格即为该竞猜价格,该人为获奖的人,如果没有唯一的竞猜价格,这找最小的价格输出竞猜次数最少的人:

思路:

用vector容器储存字符串,将相同竞猜价格的人放在一起,,用一个一维数组统计各个竞猜价格的个数,寻找只有一个数的值,寻找到的第一个就是最小的值,如果不存在唯一的值,那就找最小的那个输出!

代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<string.h>
#include<algorithm>
#include<cmath>
#include<vector>
#include<cstring>
using namespace std;

#define inf 0x3f3f3f3f
struct point
{
    string name;
    int money;
}people[1005];
int main()
{
    int u,t,flag[1005];
    int peice;
    vector<string>p[1005];
    int ans;
    while(cin>>u>>t)
    {
        for(int i=0;i<=u;i++)
        p[i].clear();
        memset(flag,0,sizeof flag);
        for(int i=0;i<t;i++)
        {
            cin>>people[i].name>>people[i].money;
            p[people[i].money].push_back(people[i].name);
            flag[people[i].money]++;
        }      //输入且初始化,统计个数,将价格相同的人放入一个数组
        int ans=inf;
        string ansname;
        bool flag1=0;
        vector<string>::iterator it;
        for(int i=0;i<=u;i++)
        {
            if(flag[i]==1)
            {
                ans=i;
                it=p[i].begin();
                ansname=*it;
                flag1=1;·
                break;
            }
        }//第一个查询不存在
        if(!flag1)
        {
            for(int i=0;i<=u;i++)
            {
                if(flag[i]>1)
                {
                    it=p[i].begin();
                    ansname=*it;
                    ans=i;
                    break;
                }
            }
        }//第二个查找
        cout<<"The winner is "<<ansname<<endl;
        cout<<"The price is "<<ans<<endl;

    }
}



猜你喜欢

转载自blog.csdn.net/u013455430/article/details/25897451