HDU 1043 Eight (bfs 康托展开 )

版权声明: https://blog.csdn.net/qq_40046426/article/details/86561358

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32621    Accepted Submission(s): 8488
Special Judge

Problem Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement.

 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

 

Sample Input

2 3 4 1 5 x 7 6 8

Sample Output

ullddrurdllurdruldr

真是秃了……为了这道题去学了康托展开,对这道题现在还是晕晕的……也算是收获挺多的。

题意是:把输入的序列转换成 1 2 3 4 5 6 7 8 x 输出路径,如果不行输出 unslovable

思路来自:https://blog.csdn.net/codeswarrior/article/details/80313475

#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
#include <map>
#include <vector>
#include <queue>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn =362880;
int fac[9];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
char step[4]={'l','r','u','d'};//与dir相反 
struct node1
{
	int fa;//指示父节点
	char step;//记录当前节点走向父节点的方向 
}node[maxn];
struct node2
{
	int aa[9];//当前序列
	int son;//康托展开表示的位置
	int n;//9的坐标 n为9在aa中的位置 
};
void Fac()//阶乘 
{
	fac[0]=1;
	for(int i=1;i<9;i++)
	{
		fac[i]=fac[i-1]*i;	
	}
 } 
int cantor(int *a)//康托展开 
{
	int ans=0;
	for(int i=0;i<9;i++)
	{
		int cnt=0;
		for(int j=i+1;j<=8;j++)
		{
			if(a[i]>a[j]) cnt++;
		}
		ans+=cnt*fac[9-i-1];
	}
	return ans;
}
void bfs()
{
	for(int i=0;i<maxn;i++)
		node[i].fa=-1;
	queue<node2> q;
	node2 a,b;
	//从终点开始逆向搜索 
	for(int i=0;i<9;i++)
	{
		a.aa[i]=i+1;
	}
	a.son=maxn;
	a.n=8;
	node[a.son].fa=0;//指向自己,表明终点 
	q.push(a);
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			b=a;
			int fx=b.n/3;
			int fy=b.n%3;//对9坐标从一维转二维 
			fx+=dir[i][0];
			fy+=dir[i][1];
			if(fx<0||fy<0||fx>2||fy>2) continue;
			b.n=3*fx+fy;//二维转一维
//			cout<<"***************"<<endl;
//			cout<<"b.aa[b.n]: "<<b.aa[b.n]<<endl;
//			cout<<"b.aa[a.n]: "<<b.aa[a.n]<<endl;
//			cout<<"***************"<<endl;
			//位置转换a.n 走向 b.n   
			int temp=b.aa[b.n];
			b.aa[b.n]=b.aa[a.n];
			b.aa[a.n]=temp;
			b.son=cantor(b.aa);
			if(node[b.son].fa==-1)//说明这个排列是第一次出现,即最少步骤 
			{
				node[b.son].fa=a.son;
				node[b.son].step=step[i];//为了后面直接输出,这里与"实际走向相反 "注意!! 
				q.push(b);
			 } 
		}
	}
 } 
int main()
{
	Fac();
	bfs();
	char get[30];
	int que[9];
	while(gets(get)>0)
	{
		int k=0;
		for(int i=0;get[i]!='\0';i++)
		{
			if(get[i]>='1'&&get[i]<='8')
				que[k++]=get[i]-'0';
			else if(get[i]=='x')
				que[k++]=9;
		}
		int s=cantor(que);
//		cout<<"11: "<<s<<endl; 
//		cout<<node[s].fa<<endl;
		if(node[s].fa==-1) cout<<"unsolvable"<<endl;
		else {
			while(node[s].fa!=0)
			{
				cout<<node[s].step;
				s=node[s].fa;
			}
			cout<<endl;
		}
	}
	return 0;
}

其他方法:https://blog.csdn.net/I_am_a_winer/article/details/43898993

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/86561358