Hdu1013(数论之九余数定理)

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 96770    Accepted Submission(s): 30060


 

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

 

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

 

Output

For each integer in the input, output its digital root on a separate line of the output.

 

Sample Input

24 39 0

 

Sample Output

6 3

      题目大意:求一个数的个位数字之和 一直加到只有一位数 输出结果

两种解法:(1)求得每个位上的数,再相加,再判断

                  (2)   九余数定理

第一种解法:

#include<iostream>
#include<cstring>
using namespace std;
int main(){
    char s[1050];
    while(cin>>s){
    	if(s[0]=='0')
    	break;
    	int len=strlen(s);
    	int sum=0;
    	int a=0,b=0;
    	for(int i=0;i<len;i++){
    		sum+=s[i]-'0';
		}
		a=sum%10;
		b=sum/10;
		int k=a+b;
		while(k>=10){
			a=k%10;
			b=k/10;
			k=a+b;
		}
		cout<<k<<endl;
	}
	return 0;
}

九余数定理:一个数对9取余等于这个数各位数相加的和对9取余,例如 123 %9 = (1+2+3)%9,然后也可以知道0-9(不包括0和9)任何数除9的余数都是等于本身比如:4%9=4.。所以想求数根,用九余数是很方便的。比如一个大于9的数除以9的余数,这个余数相当于0-9之间的某数除以9的余数(九余数定理)又因为4%9=4这个定理。更加确定树根即其余数

第二种解法:

#include<iostream>
#include<cstring>
using namespace std;
int main(){
    char s[1050];
    while(cin>>s){
    	if(s[0]=='0')
    	break;
    	int sum=0;
    	int len=strlen(s);
    	for(int i=0;i<len;i++){
    		sum+=s[i]-'0';
		}
		sum=sum%9;
		if(sum==0){
			cout<<"9"<<endl;
		}
		else{
			cout<<sum<<endl;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41515833/article/details/86559507