poj-3349哈希

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.``

大致意思是判断雪花是否相同
先输入一个n然后输入n个雪花的六个边,判断是否有相同的雪花

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<vector>
using namespace std;
const int MAXN=99991;
vector<int>hashs[MAXN];
int map[MAXN+30][6];

bool iss_same(int a,int b)
{
    int t[12],i,j,ok;
    for(i=0;i<6;i++)
        t[i]=map[a][i];
    for(i=0;i<6;i++)
        t[i+6]=map[a][i];
    for(i=0;i<6;i++)
    {
        for(j=0,ok=1;j<6;j++)
        {
            if(t[i+j]!=map[b][j]){ok=0;break;}
        }
        if(ok)
            return 1;
    }
    for(i=11;i>=6;i--)
    {
        for(j=0,ok=1;j<6;j++)
        {
            if(t[i-j]!=map[b][j]){ok=0;break;}
        }
        if(ok)
            return 1;
    }
    return 0;
}

int main()
{
    int n,i,j,k,s,ok;
    while(scanf("%d",&n)!=EOF)
    {
        ok=1;
        for(i=0;i<n;i++)
        {
            for(j=0,s=0;j<6;j++)
            {
                scanf("%d",&map[i][j]);
                s+=map[i][j];
            }
            if(ok)
            {
                s%=MAXN;
                for(k=0;k<hashs[s].size();k++)
                {
                    if(iss_same(hashs[s][k],i))
                        ok=0;
                }
                hashs[s].push_back(i);
            }
        }
        printf("%s\n",ok?"No two snowflakes are alike.":"Twin snowflakes found.");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40604099/article/details/86572182