HDU5500 Reorder the Books 规律题

http://acm.hdu.edu.cn/showproblem.php?pid=5500

Reorder the Books

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1823    Accepted Submission(s): 938


 

Problem Description

dxy has a collection of a series of books called "The Stories of SDOI",There are n(n≤19) books in this series.Every book has a number from 1 to n .

dxy puts these books in a book stack with the order of their numbers increasing from top to bottom. dxy takes great care of these books and no one is allowed to touch them.

One day Evensgn visited dxy's home, because dxy was dating with his girlfriend, dxy let Evensgn stay at home himself. Evensgn was curious about this series of books.So he took a look at them. He found out there was a story about "Little E&Little Q". While losing himself in the story,he disrupted the order of the books.

Knowing that dxy would be back soon,Evensgn needed to get the books ordered again.But because the books were too heavy.The only thing Evensgn could do was to take out a book from the book stack and and put it at the stack top.

Give you the order of the disordered books.Could you calculate the minimum steps Evensgn would use to reorder the books? If you could solve the problem for him,he will give you a signed book "The Stories of SDOI 9: The Story of Little E" as a gift.

 

Input

There are several testcases.

There is an positive integer T(T≤30) in the first line standing for the number of testcases.

For each testcase, there is an positive integer n in the first line standing for the number of books in this series.

Followed n positive integers separated by space standing for the order of the disordered books,the ith integer stands for the ith book's number(from top to bottom).


Hint:
For the first testcase:Moving in the order of book3,book2,book1 ,(4,1,2,3)→(3,4,1,2)→(2,3,4,1)→(1,2,3,4) ,and this is the best way to reorder the books.
For the second testcase:It's already ordered so there is no operation needed.

 

Output

For each testcase,output one line for an integer standing for the minimum steps Evensgn would use to reorder the books.

 

Sample Input

 

2 4 4 1 2 3 5 1 2 3 4 5

 

Sample Output

 

3 0

 

Source

BestCoder Round #59 (div.1)

可以从后往前找规律,规律是:
从后往前找,找到为n的数,n--,继续往前找,最终输出的是n
#include <iostream>
using namespace std;
int a[21];
int main()
{
    int i;
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
        {
            cin>>a[i];
        }
        for(i=n-1; i>=0; i--)
        {
            if(a[i] == n)
            {
                n = n - 1;
            }
        }
       cout<<n<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/86583969
今日推荐