ZJU 5851 Little Sub and Pascal's Triangle 数学

http://acm.zju.edu.cn/onlinejudge/showContestProblem.do?problemId=5851

soks solve(soks n)
{
    soks cnt=0;
    while(n)
    {
        cnt+=(n%2);
        n=n/2;
    }
    return cnt;
}
//计算n二进制中1的个数

Little Sub is about to take a math exam at school. As he is very confident, he believes there is no need for a review.

Little Sub's father, Mr.Potato, is nervous about Little Sub's attitude, so he gives Little Sub a task to do. To his surprise, Little Sub finishes the task quickly and perfectly and even solves the most difficult problem in the task.

Mr.Potato trys to find any possible mistake on the task paper and suddenly notices an interesting problem. It's a problem related to Pascal's Triangle.

“math”/

The definition of Pascal's Triangle is given below:

The first element and the last element of each row in Pascal's Triangle is , and the -th element of the -th row equals to the sum of the -th and the -th element of the -th row.

According to the definition, it's not hard to deduce the first few lines of the Pascal's Triangle, which is:





......

In the task, Little Sub is required to calculate the number of odd elements in the 126th row of Pascal's Triangle.

Mr.Potato now comes up with a harder version of this problem. He gives you many queries on this problem, but the row number may be extremely large. For each query, please help Little Sub calculate the number of odd elements in the -th row of Pascal's Triangle.

Input

There are multiple test cases. The first line of the input contains an integer ( ), indicating the number of test cases. For each test case:

The first and only line contains an integer ( ), indicating the required row number in Pascal's Triangle.

Output

For each test case, output the number of odd numbers in the -th line.

Sample Input

3
3
4
5

Sample Output

2
4
2
#include<bits/stdc++.h>
#define soks long long
using namespace std;
soks solve(soks n)
{
    soks cnt=0;
    while(n)
    {
        cnt+=(n%2);
        n=n/2;
    }
    return cnt;
}
int main()
{
    int T;
    soks s=1;
    soks n,ans,k;
    scanf("%d",&T);
    while(T--)
    {
        cin>>n;
        k=solve(n-1);
        ans=s<<k;
        cout<<ans<<endl;
    }
}

猜你喜欢

转载自blog.csdn.net/lanshan1111/article/details/86557212