POJ2279 Mr Young's Picture Permutations DP

Mr. Young wishes to take a picture of his class. The students will stand in rows with each row no longer than the row behind it and the left ends of the rows aligned. For instance, 12 students could be arranged in rows (from back to front) of 5, 3, 3 and 1 students. 

X X X X X
X X X
X X X
X


In addition, Mr. Young wants the students in each row arranged so that heights decrease from left to right. Also, student heights should decrease from the back to the front. Thinking about it, Mr. Young sees that for the 12-student example, there are at least two ways to arrange the students (with 1 as the tallest etc.): 

 1  2  3  4  5     1  5  8 11 12
 6  7  8           2  6  9
 9 10 11           3  7 10
12                 4


Mr. Young wonders how many different arrangements of the students there might be for a given arrangement of rows. He tries counting by hand starting with rows of 3, 2 and 1 and counts 16 arrangements: 

123 123 124 124 125 125 126 126 134 134 135 135 136 136 145 146
45  46  35  36  34  36  34  35  25  26  24  26  24  25  26  25
6   5   6   5   6   4   5   4   6   5   6   4   5   4   3   3


Mr. Young sees that counting by hand is not going to be very effective for any reasonable number of students so he asks you to help out by writing a computer program to determine the number of different arrangements of students for a given set of rows.

输入

The input for each problem instance will consist of two lines. The first line gives the number of rows, k, as a decimal integer. The second line contains the lengths of the rows from back to front (n1, n2,..., nk) as decimal integers separated by a single space. The problem set ends with a line with a row count of 0. There will never be more than 5 rows and the total number of students, N, (sum of the row lengths) will be at most 30.

输出

The output for each problem instance shall be the number of arrangements of the N students into the given rows so that the heights decrease along each row from left to right and along each column from back to front as a decimal integer. (Assume all heights are distinct.) The result of each problem instance should be on a separate line. The input data will be chosen so that the result will always fit in an unsigned 32 bit integer.

样例输入

1
30
5
1 1 1 1 1
3
3 2 1
4
5 3 3 1
5
6 5 4 3 2
2
15 15
0

样例输出

1
1
16
4158
141892608
9694845

题意:给你一个n,说明有n排(n<=5),然后给你n个数,这是每排的人数,每排按左看齐,要求从第一排到第n排高度从左到右递减,从后到前递减,第一排为最后一排      

比如这个      

1   2    3   4  

5   6    7

8   

题目说编号越小,高度越高

然后要求排列方法数

思路:把sum个人高度从大到小排列,那么只要保证那一排,比他后面的一排人数少或者相等就好了

为了方便 当n<5时,把后面几排的人数设置为0

dp[a][b][c][d][e]分别表示第1排有a个人,第二排有b个人.......时的方法数

输出dp[num[1]][num[2]][num[3]][num[4]][num[5]],题目而且保证答案在unsigned int 的范围内;

还要注意不要memset dp数组为o,会超时;;;;;;;;;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<deque>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int>P;
const int len=2e5+5;
const double pi=acos(-1.0);
const ll mod=1e9+7; 
unsigned int dp[31][31][31][31][31];
int num[6];
int main()
{	
	int n;
	while(scanf("%d",&n)&&n)
	{
		memset(num,0,sizeof(num));
		for(int i=1;i<=n;++i)scanf("%d",&num[i]);
		dp[0][0][0][0][0]=1;
		for(int a=1;a<=num[1];++a)
		for(int b=0;b<=min(num[2],b);++b)
		for(int c=0;c<=min(num[3],c);++c)
		for(int d=0;d<=min(num[4],d);++d)
		for(int e=0;e<=min(num[5],e);++e)
		{
			dp[a][b][c][d][e]=0;
			if(a-1>=b)dp[a][b][c][d][e]+=dp[a-1][b][c][d][e];
			if(b-1>=c)dp[a][b][c][d][e]+=dp[a][b-1][c][d][e];
			if(c-1>=d)dp[a][b][c][d][e]+=dp[a][b][c-1][d][e];
			if(d-1>=e)dp[a][b][c][d][e]+=dp[a][b][c][d-1][e];
			if(e-1>=0)dp[a][b][c][d][e]+=dp[a][b][c][d][e-1];
		}
		printf("%u\n",dp[num[1]][num[2]][num[3]][num[4]][num[5]]);
	}
	
}


猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/86576430