HDU1049Climbing Worm c++

Climbing Worm

题目链接
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23482 Accepted Submission(s): 16066

Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input
10 2 1
20 3 1
0 0 0

Sample Output
17
19

问题描述

有一条虫子在一口n英寸的井里,它一分钟能爬u英寸,但爬了一分钟后,必须休息1分钟,休息的这一分钟里它会下滑d英寸(u>d)。问它需要多久才能爬出这口井。

问题分析

问题很简单,只需要注意在休息前能爬出就不要再计算休息的时间了。

c++程序如下

#include<iostream>
using namespace std;
int main()
{
	int n, u, d, time, s;
	while (cin >> n >> u >> d)
	{
		if (n == 0) break;
		else
		{
			time=s = 0;
			while (s < n)
			{
				if (s + u >= n)
				{
					s += u;
					time++;
				}
				else
				{
					s += (u - d);
					time += 2;
				}
			}
		}
		cout << time << endl;
	}
	system("pause");
	return 0;
}

ACC

猜你喜欢

转载自blog.csdn.net/DouglasConnor/article/details/85008865