UVA - 1395 Slim Span Kruskal算法变形

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u011469138/article/details/83832363

Slim Span

Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.

Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).

Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), © and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1

am bm wm
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
Sample Output

1
20
0
-1
-1
1
0
1686
50
这题是要你在所有生成树中,找出最大边权-最小边权的值尽量小的生成树,思路是用kruskal算法,枚举最小边,如果所有点连通,则记录值,重新开始下一次枚举

//Kruskal
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int w[10500],u[10500],v[10500],p[10500],r[10500];
int nod=0;
int m,n;
int cmp(const int i,const int j)
{
	return w[i]<w[j];
}
int find(int x)
{
	return p[x]==x?x:p[x]=find(p[x]);
}

int Kruskal()
{
	int ans=0x3f3f3f3f;		
	for(int i=0;i<m;i++)
		r[i]=i;//按权值给边排序,同时保存id 
		
	sort(r,r+m,cmp);
	//for(int i=0;i<m;i++) printf("%d ",w[r[i]]);

	for(int i=0;i<m;i++)
	 {
		for(int k=0;k<=n;k++)
			p[k]=k;//初始化并查集
		nod=0;
	 	for(int j=i;j<m;j++)
	 	{	
		 	//cout<<w[r[j]]-w[r[i]]<<endl;
		 	int e=r[j]; 
		 	int x=find(u[e]),y=find(v[e]);
		 	if(x!=y) 
			 {
		 		//ans+=w[e];//如果计算最小生成树,就加上权值 
				p[x]=y;
				nod++;	
			 }
			if(nod==n-1)//判断所有点是否连通:n-1条边 
			{	
				nod=0;
				//cout<<ans<<endl;
				ans=min(ans,w[r[j]]-w[r[i]]);
				break;	
			}
		}
	 }
	
	if(ans==0x3f3f3f3f) ans=-1;
	return ans;
}



int main()
{
	
	while(~scanf("%d%d",&n,&m)&&(m+n)!=0)
	{
		nod=0;
		int x,y,s;
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&x,&y,&s);
			u[i]=x;
			v[i]=y;	
			w[i]=s;
		}
		
		cout<<Kruskal()<<endl;	
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u011469138/article/details/83832363