BFS_1090 Highest Price in Supply Chain (25 分)

1090 Highest Price in Supply Chain (25 分)

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

思路 

记得之前也有这样的题目,这个相对于之前的要简单很多,这个只包含一个供应商,所以只有一个根节点,这样的话,即可以使用dfs也可以使用bfs,因为bfs程序感觉写起来比较好理解,所以使用bfs来进行求解

要根据供应链找到最深的节点,并且知道最深的深度以及最深的节点的个数,注意测试用例中会包含这样的数据:

1 1.80 1.00
-1

程序

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <set>
#include <queue>
#include <cmath>
#include <map>
#define INF 0x3f3f3f3f

using namespace std;

const int maxn = 1e5+5;
typedef long long ll;
int n,s[maxn];
double p,r;
vector<int> vec[maxn];
struct Node
{
    int pos,deep;
};

void BFS(int root)
{
    int max_deep = 0,num = 1;
    queue<Node> que;
    Node tmp{root,0},node;
    que.push(tmp);
    while(!que.empty())
    {
        tmp = que.front();
        que.pop();
        for(int i = 0;i < vec[tmp.pos].size();i ++)
        {
            node.pos = vec[tmp.pos][i];
            node.deep = tmp.deep+1;
            if(node.deep > max_deep)
                max_deep = node.deep,num = 1;
            else if(node.deep == max_deep)
                num++;
            que.emplace(node);
        }
    }
    printf("%.2lf %d\n",p*pow((r/100+1),max_deep),num);
}
int main()
{
    int root;
    scanf("%d%lf%lf",&n,&p,&r);
    for(int i =0 ;i < n;i ++)
    {
        scanf("%d",s+i);
        vec[s[i]].push_back(i);
        if(s[i] == -1)
            root = i;
    }
    BFS(root);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/86686478