A + B Again#acm刷题

A + B Again

hdu-2057

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37848 Accepted Submission(s): 15333

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output

0
2C
11
-2C
-90

问题分析
输入为16进制,输出也为16进制,二我们知道16进制是没有负数的,所以要用“-”-(hex)来表示一个16进制的负数

AC的c++代码
#include<stdio.h>
#include<iostream>
using namespace std;

int main()
{
	long long int a=0,b=0,c=0;
	while (cin >> hex>>a >>hex>> b)	
	{
		c = a + b;
		if (c >= 0)
			printf("%llX\n", c);
		else
			printf("-%llX\n", -c);
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_43316754/article/details/85009891
今日推荐