Nise-Anti-AK Problem 计蒜客网络赛

水题

Description:

Peppa has been learning math recently, he is trapped by a easy problem. He is given a sequence of n numbers, what he need to do is finding the number ai which have the largest number f(ai). The function f(x)=∑(i|x) where i goes form 0 to x, | is the symbol of or-by-bit calculate.

Input:

The first line of the input has an integer T(1<=T<=10), which represents the number of test cases.

In each test case, the first line of the input contains an integers n(1<=n<=1000)--the number of the integers, next line has n integers a[i] (1 <= a[i] <= 10000).

Output:

Each test case output an integer ai which have the largest number f(ai). 

忽略每行输出的末尾多余空格

样例输入

1
3
2 3 5

样例输出

5

#include<bits/stdc++.h>
using namespace std;

int n,t;
int  a[1010];
long long ans[1010];
int i,j,now,si;

int main()
{
    scanf("%d",&n);
    while(n--)
    {
        memset(a,0,sizeof(a));
        memset(ans,0,sizeof(ans));  now=0,si=0;
        scanf("%d",&t);

        for(i=0; i<t; ++i)
        {
            cin>>a[i];
            for(j=0; j<=a[i]; ++j)
            {
                ans[i]+=(j|a[i]);
            }

        }

        for(i=0; i<t; ++i)
        {  // cout<<ans[i]<<endl;
            if(ans[i]>now)
                {
                    now=ans[i];
                    si=i;
                }

        }
        cout<<a[si]<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_27151549/article/details/80055041