POJ1917 UVA10361 Automatic Poetry【文本】

Automatic Poetry
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 2373 Accepted: 1176

Description

Background
"Oh God", Lara Croft exclaims, "it's one of these dumb riddles again!"
In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.
This time, the riddle involves poems containing a "Schuttelreim". An example of a Schuttelreim is the following short poem:
Ein Kind halt seinen Schnabel nur,
wenn es hangt an der Nabelschnur.

The Problem
A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the "action" part of Tomb Raider and not on the "intellectual" part.

Input

The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form
s1 s3 s5

where the si are possibly empty strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots "...". Lines will we at most 100 characters long.

Output

For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks "<" and ">" are removed. Line c2 is the same as l2, except that instead of the three dots the string
s4s3s2s5

should appear.

Sample Input

3
ein kind haelt seinen abel ur
wenn es haengt an der ...
weil wir zu spaet zur <>oma amen
verpassten wir das ...
u ist
...

Sample Output

ein kind haelt seinen schnabel nur
wenn es haengt an der nabel schnur
weil wir zu spaet zur oma kamen
verpassten wir das koma amen
du bist
bu dist

Source

TUD Programming Contest 2001, Darmstadt, Germany

问题链接POJ1917 UVA10361 Automatic Poetry
问题简述:(略)
问题分析
    这个是一个文本处理题,用C++的string类有关的函数(方法)就可以实现了。关键是要了解那些函数及其参数的使用。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ1917 UVA10361 Automatic Poetry */

#include <iostream>
#include <string>

using namespace std;

int main()
{
    int n;
    string i1, i2;

    cin >> n;
    getline(cin, i1);
    while(n--) {
        int pos1, pos2, pos3, pos4, pos5;

        getline(cin, i1);
        getline(cin, i2);

        pos1 = i1.find('<');
        pos2 = i1.find('>', pos1);
        pos3 = i1.find('<', pos2);
        pos4 = i1.find('>', pos3);
        pos5 = i2.find('.');

        string s1 = i1.substr(0, pos1);
        string s2 = i1.substr(pos1+ 1, pos2 - pos1 - 1);
        string s3 = i1.substr(pos2 + 1, pos3 - pos2 - 1);
        string s4 = i1.substr(pos3 + 1, pos4 - pos3 - 1);
        string s5 = i1.substr(pos4 + 1);
        string s6 = i2.substr(0, pos5);

        cout << s1 << s2 << s3 << s4 << s5 << endl;
        cout << s6 << s4 << s3 << s2 << s5 << endl;
    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/tigerisland45/p/10386234.html