HDU1564 Play a game

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1564

Play a game

Problem Description

New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner (“8600” or “ailyanlu”) for each input line except the last zero.
No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

8600

题解

很显然的一道题,石子可以上下左右移动到没有到过的格子,而石子肯定可以遍历整个棋盘,所以我们只需要看格子数是奇是偶就可以判断了。

代码
#include<bits/stdc++.h>
using namespace std;
int n;
void ac()
{
    if(n%2)printf("ailyanlu\n");
    else printf("8600\n");
}
int main()
{
    while(scanf("%d",&n)&&n)ac();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ShadyPi/article/details/79940125