PAT(A) 1125. Chain the Ropes (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/huqiao1206/article/details/79531161

title: PAT(A) 1125. Chain the Ropes (25)
tags: PAT
categories: PAT甲级
date: 2018-03-12 16:12:17
description:
updated:
comments:
permalink:

原题目:

原题链接:https://www.patest.cn/contests/pat-a-practise/1125

1125. Chain the Ropes (25)


Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14

题目大意

有N个绳子,每两个可以合成一个,但总长度会减半。现求出能合并出的最长的距离。

解题报告

有哈夫曼的思想,先合成的后期还要再被合成,所以短的先结合,长的最后,于是每次取最短的两个,合成加进去。
用优先队列。

代码

/*
* Problem: 1125. Chain the Ropes (25)
* Author: HQ
* Time: 2018-03-12
* State: Done
* Memo: 优先队列
*/
#include "iostream"
#include "queue"
#include "functional"
using namespace std;

priority_queue<double, vector<double>, greater<double> > ropes;
int N;

int main() {
	cin >> N;
	double x,y;
	for (int i = 0; i < N; i++) {
		cin >> x;
		ropes.push(x);
	}
	while (ropes.size() > 1) {
		x = ropes.top();
		ropes.pop();
		y = ropes.top();
		ropes.pop();
		ropes.push((x + y) / 2);
	}
	cout << (int)ropes.top() << endl;
	system("pause");
}

猜你喜欢

转载自blog.csdn.net/huqiao1206/article/details/79531161
今日推荐