今日学习——有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

Sample Input

6 5
1 23 26 45 66 99
14 21 28 50 100

Sample Output

1 14 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

Source

#include<stdio.h>
#include<stdlib.h>
struct node//构建结点
{
    int number;
    struct node *next;
};
typedef struct node NODE;
NODE *creat(int n)//构建链表(头插法)
{
    NODE *p ,*q, *head;
    head=(NODE*)malloc(sizeof(NODE));
    head->next=NULL;
    q=head;
    int i;
    for(i=0;i<n;i++)
    {
        p=(NODE*)malloc(sizeof(NODE));
        p->next=NULL;
        scanf("%d",&p->number);
        q->next=p;
        q=p;
    }
    return head;
}
NODE *he(NODE *a,NODE *b)//将两个链表合并
{
    NODE *p ,*q ,*head;
    p=a->next;
    q=b->next;
    head=a;
    free(b);
    while(p&&q)
    {
        if(p->number>q->number)
        {
            head->next=q;
            head=q;
            q=q->next;
        }
        else
        {
            head->next=p;
            head=p;
            p=p->next;
        }
    }
    if(p)
    {
        head->next=p;
    }
    else
    {
        head->next=q;
    }
    return a;
}
int main()
{
    int n , m;
    NODE *head1,*head2,*head,*p;
    scanf("%d %d",&m,&n);
    head1=creat(m);
    head2=creat(n);
    head=he(head1,head2);
    p=head->next;
    while(p)
    {
        printf("%d",p->number);
        if(p->next!=NULL)
            printf(" ");
        else printf("\n");
        p=p->next;
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/qq_43345339/article/details/84969264