动态规划_Apple Catching_POJ-2385

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 
Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 
Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W * Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute. Output * Line 1: The maximum number of apples Bessie can catch without walking more than W times. Sample Input 7 2 2 1 1 2 2 1 1 Sample Output 6 Hint INPUT DETAILS: Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. OUTPUT DETAILS: Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

仍然是道很经典的动态规划,比起之前的手足无措,这题有了不少的思路,但是由于对状态的定义不太好导致牵连着对状态间的转移也变得模糊起来。

开始是把dp[i][j]定义为第i分钟时,可移动次数还有j次时得到的苹果数量,参考别人博客后发现自己这样的定义并不好。

老规矩,首先定义状态:dp[i][j]表示在第i分钟时,已经移动了j次后得到的苹果数量

接着来看状态转移方程:dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]) ,然后判断当前是否在第i分钟掉苹果的那颗树下,是的话,dp[i][j]++

解释(以下提供几种描述):

1.对于第i秒移动j次的状态,可以由两种前驱状态转移得来,一种是i-1秒时就已经移动了j次,然后第i秒就不移动了,另一种是i-1秒移动了j-1次,然后她还可以再移动一次得到移动j次。

2.第i分钟能得到的苹果数量,等于在第i-1分钟时,在树1和树2下得到苹果的最大值(j为偶数则在树1下面,奇数则在树2下面)

3.在第i分钟奶牛到某棵树下有两种状态:1.从另一棵树走过来(dp[i-1][j-1])    2.本来就呆在这棵树下(dp[i-1][j])

由于移动偶数次可以回到树1,移动奇数次可以回到树2,移动j次时,若j%2+1==a[i]就表明当前位置恰好有苹果落下。

最后须注意下初始化与边界计算

附上AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;
 
const int maxn = 1005;
 
int a[maxn], dp[maxn][40];

int main()
{
    int t, w;
    while(~scanf("%d%d", &t, &w)) {
        for(int i = 1; i <= t; i++)
            scanf("%d", &a[i]);
        if(a[1] == 1) {
            dp[1][0] = 1, dp[1][1] = 0;
        }
        else {
            dp[1][0] = 0, dp[1][1] = 1;
        }
        for(int i = 2; i <= t; i++) {
            for(int j = 0; j <= w; j++) {
                if(j == 0) dp[i][j] = dp[i-1][j] + a[i]%2;
                else {
                    dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]);
                    if(j%2+1 == a[i]) dp[i][j]++;
                }
            }
        }
        
        int ans = 0;
        for(int i = 0; i <= w; i++)
            ans = max(ans, dp[t][i]);
        printf("%d\n", ans);
    }
    
    return 0;
}

刚发现有按照我那种思路来的,但是明天要考试了,得看下C语言准备下,先放上博客地址,回头再看

https://www.cnblogs.com/Philip-Tell-Truth/p/4815021.html

猜你喜欢

转载自www.cnblogs.com/wizarderror/p/10496236.html