PAT (Advanced Level) 1117 Eddington Number (25 分)

版权声明:转载请附链接 https://blog.csdn.net/isunLt/article/details/87898652

1117 Eddington Number (25 分)

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.
Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
int main()
{
	int n;
	scanf("%d", &n);
	vector<int> vec(n);
	for (int i = 0; i < n; i++)
		scanf("%d", &vec[i]);
	sort(vec.begin(), vec.end(), [](const int n1, const int n2) {
		return n1 > n2;
	});
	int ans = 0;
	while (ans < n && vec[ans] > ans+1) ans++;
	printf("%d\n", ans);
	return 0;
}

思路:

https://www.liuchuo.net/archives/2478

猜你喜欢

转载自blog.csdn.net/isunLt/article/details/87898652
今日推荐