杭电2009-------求数列的和C++ 版

这里是引用
Problem Description
数列的定义如下:
数列的第一项为n,以后各项为前一项的平方根,求数列的前m项的和。

Input
输入数据有多组,每组占一行,由两个整数n(n<10000)和m(m<1000)组成,n和m的含义如前所述。

Output
对于每组输入数据,输出该数列的和,每个测试实例占一行,要求精度保留2位小数。

Sample Input
81 4
2 2

Sample Output
94.73
3.41

Author
lcy

Source
C语言程序设计练习(二)

#include<iostream>
using namespace std;
#include<cmath>
#include<iomanip>
void f(double n,int m)
{
    double a=0,i;
    for(i=0;i<m;i++)
    {
       a+=n;
       n=sqrt(n);
    }
    cout<<fixed<<setprecision(2)<<a<<endl;
}
int main()
{
    double n,m;
    while(cin>>n>>m)
    {
        f(n,m);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43289087/article/details/88580813