B - A strange lift

原文:https://vjudge.net/contest/286102#problem/B

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

思路:由于n最大为200,用dfs必然会TLE,所以可以用bfs,由于只有两种走法,要么往下,要么往上

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 100000+5;
int book[300];
int n,a,b; 
typedef struct 
{
	int cur;
	int step;
}Node;

int res[300];

void bfs()
{
	int front = 0,rear = 0;
	Node node[maxn];
	node[rear].cur = a;
	node[rear++].step = 0;
	while(front < rear)
	{
		Node t = node[front++];
		
		if(t.cur == b)
		{
			printf("%d\n",t.step);
			return ;
		}
		
		for(int i = 1;i <= 2;++i)
		{
			int tcur = t.cur;
			if(i == 1)
			{
				tcur += res[t.cur];
				
			}
			else 
			{
				tcur -= res[t.cur];
				
			}
			
			if(tcur < 1 || tcur > n) continue;
			
			//判断是否经过此层,就不需要再加入队列中,防止死循环发生
			if(!book[tcur])
			{
				book[tcur] = 1;
				node[rear].cur = tcur;
				node[rear++].step = t.step+1;
			}
		}
	}

        //如果没有找到,就输出-1
	printf("-1\n");
}



int main()
{

    while(scanf("%d",&n) && n)
    {
    	scanf("%d%d",&a,&b);
    	memset(book,0,sizeof(book));
    	for(int i = 1;i <= n;++i)
    	    scanf("%d",&res[i]);
    	bfs();
    }
    
    return 0;

}

猜你喜欢

转载自blog.csdn.net/qq_40511966/article/details/88547639
今日推荐