POJ - 1503

Integer Inquiry
One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

This supercomputer is great,'' remarked Chip.I only wish Timothy were here to see these results.’’ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.

Output
Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output
370370367037037036703703703670

大数据开头可能会有前导零!!!!!
去掉判定条件你就A了!!!!!

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int N=1e5;
int i,j,a[N],b[N],n;
int add(int a[],int b[])
{
    int i,k;
    k=a[0]>b[0]?a[0]:b[0];
    for(i=1;i<=k;i++)
    {
        a[i+1]+=(a[i]+b[i])/10;
        a[i]=(a[i]+b[i])%10;
    }
    if(a[k+1]>0)
        a[0]=k+1;
    else
        a[0]=k;
    return 0;
}
int main()
{
    string s;
    memset(a,0,sizeof(a));
    while(cin>>s)
    {
        getchar();
        memset(b,0,sizeof(b));
        b[0]=s.size();
        for(j=1;j<=b[0];j++)
            b[j]=s[b[0]-j]-48;
        add(a,b);
    }
    for(i=a[0];i>0;i--)
        cout<<a[i];
    cout<<'\n';
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43871207/article/details/88543952