zoj 3778 Talented Chef

题目:
As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.
To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Ai steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most M different dishes and finish one step for each dish chosen.
Coach Gao wants to know the least time he needs to prepare the dinner.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains two integers N and M (1 <= N, M <= 40000). The second line contains N integers Ai (1 <= Ai <= 40000).
Output
For each test case, output the least time (in minute) to finish all dishes.
Sample Input
2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10
Sample Output
3
10
代码如下:

#include<iostream>
#include<cstdio> 
using namespace std;
int a[40005];
int main()
{
	int t,n,m,maxn,sum,minx,ans;
	cin >> t;
	while(t--){
		cin >> n >> m;
		maxn = sum = 0;
		for(int i = 0;i < n;i++){
			cin >> a[i];
			maxn = max(maxn,a[i]);
			sum += a[i];
		}
		minx = min(n,m);
		ans = sum / minx;
		if(sum % minx) ans++;
		if(ans < maxn) ans = maxn;
		cout << ans << endl;
	}
	return 0; 
} 

题意:
有n个饼,有m个锅子(也就是说可以同时煮m个饼),然后给出n个饼煮完的时间,输出煮完所有饼花费的最少时间。
思路:
一开始想从大到小排序,每次都让前m个饼时间-1,最后数组全部值为0后输出时间。这样毫无疑问会超时,我们应该先把m和n中较小的值求出来,因为如果锅子数量大于饼数,那你能用的锅数量就是饼的个数(也就是说有些锅子不用)。然后求出所有饼煮完的总是时间以及花费最长时间的饼,ans = sum / minx表示当饼时间比较均匀时可以这么计算时间。但是如果出现比如1,1,2,999这种情况呢?ans就不是最终的时间了,此时ans < maxn 所以最少也要花999的时间(也就是花费最长时间的饼)。

猜你喜欢

转载自blog.csdn.net/qq_41998938/article/details/88726584
ZOJ