hdu1498二分图最小覆盖点集行列建边

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons". 

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons. 

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times. 

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0. 

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1". 

Sample Input

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

Sample Output

-1
1
2
1 2 3 4 5
-1

对于每一种颜色,把这种颜色所在的点的行和列分别作为左右点集连边,最后这些边覆盖了所有的这种颜色,因为一次可以选一行或者一列把这种颜色全消,就等于选最少的顶点包含这些全部的边集,也就是求一个最小覆盖,然后暴力扫一遍所有已经存在的颜色,如果最小覆盖集都比k大,就不可能全消,保存下来即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 1005
using namespace std;

int map[maxn][maxn];
int lef[maxn];
int vis[maxn];
int ans[maxn];
int n,k;
int cnt;
int color[maxn];
bool dfs(int i,int co)
{
    for(int j=0;j<n;j++)
    {
        if(!vis[j]&&map[i][j]==co)
        {
            vis[j]=true;
            if(lef[j]==-1||dfs(lef[j],co))
            {
                lef[j]=i;
                return true;
            }
        }
    }
    return false;
}
int km(int co)
{
    memset(lef,-1,sizeof(lef));
    int ans=0;
    for(int i=0;i<n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i,co))
            ans++;
    }
    return ans;

}
int main()
{while(~scanf("%d%d",&n,&k))
{if(n==0&&k==0)
break;
memset(ans,0,sizeof(ans));
    memset(color,0,sizeof(color));
cnt=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
        scanf("%d",&map[i][j]);
        color[map[i][j]]=1;
    }
}
for(int i=1;i<=50;i++)
{
    if(color[i])
    {
        if(km(i)>k)
          ans[cnt++]=i;
    }
}
sort(ans,ans+cnt);
if(cnt==0)
    printf("-1\n");
else
{for(int i=0;i<cnt-1;i++)
    printf("%d ",ans[i]);
printf("%d\n",ans[cnt-1]);

}
}
return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/88539820