HDU 4772 Zhuge Liang's Password(模拟)

版权声明:这些都是咸鱼Nova最后的挣扎,各位大佬转载请注明出处 https://blog.csdn.net/weixin_40883049/article/details/78917657

传送门 HDU 4772

Zhuge Liang's Password

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3168    Accepted Submission(s): 1869


Problem Description
  In the ancient three kingdom period, Zhuge Liang was the most famous and smart military leader. His enemy was Sima Yi, the military leader of Kingdom Wei. Sima Yi always looked stupid when fighting against Zhuge Liang. But it was Sima Yi who laughed to the end. 
  Zhuge Liang had led his army across the mountain Qi to attack Kingdom Wei for six times, which all failed. Because of the long journey, the food supply was a big problem. Zhuge Liang invented a kind of bull-like or horse-like robot called "Wooden Bull & Floating Horse"(in abbreviation, WBFH) to carry food for the army. Every WBFH had a password lock. A WBFH would move if and only if the soldier entered the password. Zhuge Liang was always worrying about everything and always did trivial things by himself. Since Ma Su lost Jieting and was killed by him, he didn't trust anyone's IQ any more. He thought the soldiers might forget the password of WBFHs. So he made two password cards for each WBFH. If the soldier operating a WBFH forgot the password or got killed, the password still could be regained by those two password cards.
  Once, Sima Yi defeated Zhuge Liang again, and got many WBFHs in the battle field. But he didn't know the passwords. Ma Su's son betrayed Zhuge Liang and came to Sima Yi. He told Sima Yi the way to figure out the password by two cards.He said to Sima Yi: 
  "A password card is a square grid consisting of N×N cells.In each cell,there is a number. Two password cards are of the same size. If you overlap them, you get two numbers in each cell. Those two numbers in a cell may be the same or not the same. You can turn a card by 0 degree, 90 degrees, 180 degrees, or 270 degrees, and then overlap it on another. But flipping is not allowed. The maximum amount of cells which contains two equal numbers after overlapping, is the password. Please note that the two cards must be totally overlapped. You can't only overlap a part of them."
  Now you should find a way to figure out the password for each WBFH as quickly as possible.
 

Input
  There are several test cases.
  In each test case:
  The first line contains a integer N, meaning that the password card is a N×N grid(0<N<=30).
  Then a N×N matrix follows ,describing a password card. Each element is an integer in a cell. 
  Then another N×N matrix follows, describing another password card. 
  Those integers are all no less than 0 and less than 300.
  The input ends with N = 0
 

Output
  For each test case, print the password.
 

Sample Input
 
  
2 1 2 3 4 5 6 7 8 2 10 20 30 13 90 10 13 21 0
 

Sample Output
 
  
0 2

题目大意:给你两个n阶的矩阵,每个矩阵可以旋转,问旋转之后对应位置上最多有多少个数是相同的

心路历程:直接暴力写(第一次写一脸懵逼,现在可以行云流水了)


ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int n,arr[33][33],brr[33][33],tmp[33][33];
//比较函数,返回相同的个数
int cmp(){
    int sum=0;
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            if(arr[i][j]==brr[i][j]) sum++;
    return sum;
}
//旋转函数
int clock(){
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            tmp[i][j]=arr[j][n-i-1];//注意这步的旋转操作
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            arr[i][j]=tmp[i][j];//写回原来的矩阵
    return cmp();
}


int main(){
    while(scanf("%d",&n)&&n){
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&arr[i][j]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                scanf("%d",&brr[i][j]);
        int maxn=0;
        for(int i=0; i<4; i++)//旋转四次
            maxn = max(maxn,clock());
        printf("%d\n",maxn);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/weixin_40883049/article/details/78917657
今日推荐