POJ - 2250 Compromise POJ

In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do. 

Therefore the German government requires a program for the following task: 
Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind). 

Your country needs this program, so your job is to write it for us.

Input

The input will contain several test cases. 
Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '#'. 
Input is terminated by end of file.

Output

For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.

Sample Input

die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample Output

die einkommen der abgeordneten muessen dringend verbessert werden

题目大意:给出两个文本,每一个文本以#号结束,输出两个文本的最长公共子序列(以单词为单位,单词之间以空格分开

解题思路:LCS模板题, 一维以字符串为单位,所以建立string数组就行了

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
using namespace std;
const int maxn=110;
string a[maxn],b[maxn],ans[maxn];
int dp[maxn][maxn],dir[maxn][maxn],cnt;

void find(int x,int y)
{
	if(x==0||y==0)
		return;
	if(dir[x][y]==0)
	{
		find(x-1,y-1);
		ans[cnt++]=a[x];
	}
	if(dir[x][y]==1)
		find(x-1,y);
	if(dir[x][y]==2)
		find(x,y-1);
}

int main()
{
	string s;
	while(cin>>a[1])
	{
		int alen=2;
		while(cin>>s&&s!="#")
		{
			a[alen++]=s;
		}
			
		cin>>b[1];
		int blen=2;
		while(cin>>s&&s!="#")
		{
			b[blen++]=s;
		}
		for(int i=0;i<alen;i++)
		{
			for(int j=0;j<blen;j++)
			{
				if(i==0||j==0)
					dp[i][j]=0;
				else if(a[i]==b[j])
				{
					dp[i][j]=dp[i-1][j-1]+1;
					dir[i][j]=0;
				}
				else
				{
					if(dp[i-1][j]>dp[i][j-1])
					{
						dp[i][j]=dp[i-1][j];
						dir[i][j]=1;
					}
					else
					{
						dp[i][j]=dp[i][j-1];
						dir[i][j]=2;
					}
				}
			}
		}
		cnt=0;
		find(alen-1,blen-1);
		for(int i=0;i<cnt;i++)
		{
			if(i==0)
				cout<<ans[i];
			else
				cout<<' '<<ans[i];
		}
		cout<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/87934813