最流行的气球

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
题解思路:本题利用二维数组和strcmp函数,考察的大家的基础知识点.

#include<stdio.h>
#include<string.h>
int main()
{
    char a[1000][1000];
    int n,k;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
        scanf("%s",a[i]);
        int max=0,sum;
        for(int i=0;i<n;i++)
        {
            sum=0;
            for(int j=0;j<n;j++)
            {
                if(strcmp(a[i],a[j])==0)
                {
                    sum++;
                }
            }
            if(sum>max)             //每执行一次for(i)循环,都会和a[j]每个元素进行比较,从而得出数组里面有几个重样的
            {
                max=sum;
                k=i;                //再根据重样的次数的比较记下最大的 i 值(还要注意每次比较要清零sum)
            }
        }
        printf("%s\n",a[k]);        
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_43888067/article/details/86155162