PAT(甲级)1005 Spell It Right (20 分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

简述大意:输入一串数,然后每个位数相加,得到一个新的数,然后再一个一个输出每个位数的英文

可以将这个数每次对10取余,也可以换成字符串操作。。反正这道很简单

#include<iostream>
using namespace std;
int main()
{
    string a;
    cin >> a;
    int sum = 0;
    for (int i = 0; i < a.length();i++)
    {
        sum += (a[i] - '0');
    }
    string s = to_string(sum);
    string arr[10] = {"zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    cout<< arr[s[0] - '0'];
    for (int i = 1; i < s.length(); i++)
        cout << " " << arr[s[i] - '0'];
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35601980/article/details/88768966
今日推荐