PAT A1080

  • 题目:
    It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade G​E​​, and the interview grade G​I​​. The final grade of an applicant is (G​E​​+G​I​​)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade G​E​​. If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one's turn to be admitted; and if the quota of one's most preferred shcool is not exceeded, then one will be admitted to this school, or one's other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:

Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s G​E​​ and G​I​​, respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M−1, and the applicants are numbered from 0 to N−1.
Output Specification:

For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.
Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

  • 分析:
    1.结构体node里面包括,id,总分,GRE分数,G1,以及容器chioce,里面存放的为选择的学校id。temp数组里面存放,每个学校已经录取的人数,res数组,里面每个元素为一个容器,容器里面存放的为学生id,full数组存放的为每个学校计划招生数
    2.将学生按照总分从大到小排序如总分相同,则比较GRE分数
    3.当学校未招满 || 招进的人的排名与最后一位招进的人排名相同,则将其加入res中相应的容器
    4.total 用GRE与G1之和替代
    5.注意输出格式

代码实现:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node{
    int  total;
    int GRE, G1, id;
    vector<int> choice;
};
bool cmp(node& a, node& b){
    if(a.total != b.total)
        return a.total > b.total;
    return a.GRE > b.GRE;
}
bool cmp1(node& a, node& b){
    return a.id < b.id;
}
int main()
{
    int N, M, K, num, choice, GRE, G1,full[110],temp[110] = {0};   //N总人数, M学校数, K选择数
    scanf("%d%d%d", &N, &M, &K);
    for(int i = 0; i < M; i++)         //每个学校计划招生人数
        scanf("%d", &full[i]);
    vector<node> stu(N), res[100];               //学生人数
    for(int i = 0; i < N; i++){
        scanf("%d%d", &GRE, &G1);
        stu[i].id = i;
        stu[i].GRE = GRE;
        stu[i].G1 = G1;
        stu[i].total = (GRE+ G1);
        stu[i].choice.resize(K);
        for(int j = 0; j < K; j++){
            scanf("%d", &choice);
            stu[i].choice[j] = choice;
        }
    }
    sort(stu.begin(), stu.end(), cmp);
    for(int i = 0; i < N; i++){
        for(int  j = 0; j < K; j++){
            int sch_id = stu[i].choice[j];
            int last = temp[sch_id]-1;
            if(temp[sch_id] < full[sch_id] || (stu[i].total == res[sch_id][last].total) && stu[i].GRE == res[sch_id][last].GRE)
            {
                temp[sch_id]++;
                res[sch_id].push_back(stu[i]);
                break;
            }
        }
    }
   for(int i = 0; i < M; i++){
        sort(res[i].begin(), res[i].end(), cmp1);
        for(int j = 0; j < res[i].size(); j++){
            if(j != 0)
                printf(" ");
            printf("%d", res[i][j].id);
   }
   printf("\n");
   }
return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao1guaishou/article/details/88919003
今日推荐