【POJ - 1651】Multiplication Puzzle(区间dp)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/88901114

题干:

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

扫描二维码关注公众号,回复: 5799743 查看本文章
3650

解题报告:

   dp[l][r]代表我要消掉 l~r 中间的所有数字。转移显然是枚举最后一个操作需要删掉的数字,然后转移就行了。

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 100 + 5;
ll dp[MAX][MAX];
ll a[MAX];
int main()
{
	int n;
	cin>>n;
	for(int i = 1; i<=n; i++) scanf("%lld",a+i);
	memset(dp,0x3f,sizeof dp);
	for(int i = 1; i<=n; i++) dp[i][i] = 0,dp[i][i+1] = 0;
	for(int len = 3; len<=n; len++) {
		for(int l = 1; l+len-1 <= n; l++) {
			int r = l + len - 1;
			if(len == 3) {
				dp[l][r] = a[l]*a[r]*a[l+1];
				continue;
			}
			for(int k = l+1; k<=r-1; k++) {
				dp[l][r] = min(dp[l][r] , dp[l][k] + dp[k][r] + a[l]*a[k]*a[r]);
			}
		}
	}
	cout <<dp[1][n];
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/88901114