HDU - 1078 FatMouse and Cheese 记忆化搜索

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

思路:

记忆化搜索,当前状态的最优解, 是由下一状态的最优解加上当前状态的值,最后回溯到起点,就是从起点出发的最优解

AC代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
#include<string>
#include<map>
#define INF 0x3f3f3f3f
#define rep(i,a,n) for(int i=a;i<n;i++)
#define per(i,a,n) for(int i=n-1;i>=a;i--)
#define fori(x) for(int i=0;i<x;i++)
#define forj(x) for(int j=0;j<x;j++)
#define memset(x,y) memset(x,y,sizeof(x))
#define memcpy(x,y) memcpy(x,y,sizeof(y))
#define sca(x) scanf("%d", &x)
#define scas(x) scanf("%s",x)
#define sca2(x,y) scanf("%d%d",&x,&y)
#define sca3(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define scl(x) scanf("%lld",&x)
#define scl2(x,y) scanf("%lld%lld",&x,&y)
#define scl3(x,y,z) scanf("%lld%lld%lld",&x,&y,&z)
#define pri(x) printf("%d\n",x)
#define pri2(x,y) printf("%d %d\n",x,y)
#define pris(x) printf("%s\n",x)
#define prl(x) printf("%lld\n",x)
//#include <bits/stdc++.h>

typedef long long ll;
const int maxn=1e6+7;
const int mod=1e9+7;
const double eps=1e-8;

using namespace std;

int n,k;
int dir[4][2] = {1,0,-1,0,0,-1,0,1};
int dp[1050][1050];
int a[1050][1050];
bool f(int x,int y)
{
  if(x>=0 && x<n && y>=0 && y<n)
    return true;
  return false;
}
int dfs(int x,int y)
{
    if(dp[x][y])
      return dp[x][y];
    int ma = 0;
    dp[x][y] = a[x][y];
    rep(i,0,4)
    {
      rep(j,1,k+1)
      {
        int xx = x + dir[i][0] * j;
        int yy = y + dir[i][1] * j;
        if(f(xx,yy) && a[xx][yy] > a[x][y])
        {
          ma = max(ma,dfs(xx,yy));
        }
      }
    }
    dp[x][y] += ma;
    return dp[x][y];
}
int main()
{
    while(sca2(n,k) &&  n+k != -2)
    {
      memset(dp,0);
      rep(i,0,n)
      {
        rep(j,0,n)
        {
          sca(a[i][j]);
        }
      }
      dfs(0,0);
      printf("%d\n",dp[0][0]);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/Prince_NYing/article/details/88935480