1136 A Delayed Palindrome (20 分)

1136 A Delayed Palindrome (20 分)

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​⋯a​1​​a​0​​ with 0≤a​i​​<10 for all i and a​k​​>0. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number -- in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

解题思路:心态不好就是大坑。该题有三个测试点输入即为回文串,因此要注意判断!

做PAT真的需要一个强大的心态,坑点太多。

#include <iostream>
#include <bits/stdc++.h>
#include <string>
using namespace std;

string rev(string s)
{
    string ans;
    for(int i = s.size()-1; i >= 0; i--){
        ans += s[i];
    }
    return ans;
}

bool isPalindrome(string s)
{
    int n = s.size();
    for(int i = 0; i < n/2; i++){
        if(s[i]!=s[n-i-1]) return false;
    }
    return true;
}

string Plus(string s1,string s2)
{
    int ans[1005];
    reverse(s1.begin(), s1.end());
    reverse(s2.begin(), s2.end());
    int n = s1.size();
    int c = 0;
    for(int i = 0; i < n; i++){
        int d1 = s1[i]-'0';
        int d2 = s2[i]-'0';
        ans[i] = (d1+d2+c)%10;
        c = (d1+d2+c)/10; //进位一定要在后面求
    }
    ans[n] = c;
    string s;
    bool flag = false;
    for(int i = n; i >= 0; i--){
        if(ans[i]==0&&!flag) continue;
        flag = true;
        s += to_string(ans[i]);//c++11特性
    }
    return s;
}

int main()
{
    string s;
    int len = 10;
    cin >> s;
    while(len--){
        if(isPalindrome(s)){//输入即回文
            cout << s << " is a palindromic number.";
            return 0;
        }
        string ans = Plus(s,rev(s));
        cout << s << " + " << rev(s) << " = " << ans << endl;
        if(isPalindrome(ans)){
            cout << ans << " is a palindromic number.";
            return 0;
        }
        s = ans;
    }
    cout << "Not found in 10 iterations.";
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_36313227/article/details/89135274
今日推荐