1327 平面上的点和线——Point类、Line类 (I)

题目描述

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。

根据“append.cc”,完成Point类和Line类的构造方法和show()方法。

接口描述:

Point::show()方法:按格式输出Point对象。

Line::show()方法:按格式输出Line对象。

输入

输入的第一行为N,表示后面有N行测试样例。

每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

输出

输出为多行,每行为一条线段,起点坐标在前终点坐标在后,每个点的X坐标在前,Y坐标在后,Y坐标前面多输出一个空格,用括号包裹起来。输出格式见sample。

样例输入

4 0,0 1,1 1,1 2,3 2,3 4,5 0,1 1,0

样例输出

Point : (0, 0)

Line : (0, 0) to (1, 1)

Line : (1, 1) to (2, 3)

Line : (2, 3) to (4, 5)

Line : (0, 1) to (1, 0)

Line : (1, -2) to (2, -1)

Line : (1, -2) to (0, 0)

Line : (2, -1) to (0, 0)

Line : (0, 0) to (2, -1)

提示

Append Code

append.cc,

#include<iostream>
#include<string>
using namespace std;
class Point
{public:
    double x;
    double y;
 
    Point(){x=0;y=0;}
    Point(double a,double b){x=a;y=b;}
    ~Point(){}
    void show(){cout<<"Point : ("<<x<<", "<<y<<")"<<endl;}
};
class Line
{
private:
    Point A;
    Point B;
public:
    Line(double x1,double y1,double x2,double y2)
    {
        A.x=x1;
        A.y=y1;
        B.x=x2;
        B.y=y2;
    }
    Line(Point C,Point D):A(C),B(D){}
    ~Line(){}
    void show()
    {
        cout<<"Line : ("<<A.x<<", "<<A.y<<") to ("<<B.x<<", "<<B.y<<")"<<endl;
    }
};
int main()
{
    char c;
    int num, i;
    double x1, x2, y1, y2;
    Point p(1, -2), q(2, -1), t;
    t.show();
    std::cin>>num;
    for(i = 1; i <= num; i++)
    {
        std::cin>>x1>>c>>y1>>x2>>c>>y2;
        Line line(x1, y1, x2, y2);
        line.show();
    }
    Line l1(p, q), l2(p, t), l3(q, t), l4(t, q);
    l1.show();
    l2.show();
    l3.show();
    l4.show();
}

猜你喜欢

转载自blog.csdn.net/qq_43510106/article/details/89360226
今日推荐