POJ - 3159 Candies (差分约束 + spfa)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/chimchim04/article/details/89004558

Candies

 题目链接:https://vjudge.net/problem/POJ-3159

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and cin order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题目大意:有n个小孩,m个约束条件,每个约束条件为A B C表示A认为B不应该比自己多超过C个糖。问你1号小孩和n号小孩最多相差多少个糖

思路:要满足 B-A<=C 即满足 B<=A+C    和最短路要满足的条件相同  if(d[v] < d[u] + dist(u,v)) d[v] = d[u] + dist(u,v)  所以就是最短路

代码:
 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f
const int N=300005;
const int M=400005;
int n,m,tot;
struct node
{
    int v,w,next;
} E[N];
int first[N],dis[N],vis[N];
void add(int u,int v,int w)
{
    E[tot].v = v, E[tot].w = w;
    E[tot].next = first[u];
    first[u] = tot++;
}
void spfa(int st)
{
    for(int i=0; i<=n; i++)
    {
        dis[i]=inf;
        vis[i]=0;
    }
    vis[st]=1;
    dis[st]=0;
    stack<int>s;
    s.push(st);
    while(!s.empty())
    {
        st=s.top();
        s.pop();
        vis[st]=0;
        for(int i=first[st]; i!=-1; i=E[i].next)
        {
            if(dis[E[i].v]>dis[st]+E[i].w)
            {
                dis[E[i].v]=dis[st]+E[i].w;
                if(!vis[E[i].v])
                {
                    vis[E[i].v]=1;
                    s.push(E[i].v);
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        tot=1;
        memset(first,-1,sizeof(first));
        int a,b,c;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            add(a,b,c);
        }
        spfa(1);
        printf("%d\n",dis[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/chimchim04/article/details/89004558