Sicily 1240. Faulty Odometer

  1. Faulty Odometer

Constraints
Time Limit: 1 secs, Memory Limit: 32 MB

Description
You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 3 to the digit 5, always skipping over the digit 4. This defect shows up in all positions (the one’s, the ten’s, the hundred’s, etc.). For example, if the odometer displays 15339 and the car travels one mile, odometer reading changes to 15350 (instead of 15340).

Input
Each line of input contains a positive integer in the range 1…999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 4.

Output
Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input
13
15
2003
2005
239
250
1399
1500
999999
0

Sample Output
13: 12
15: 13
2003: 1461
2005: 1462
239: 197
250: 198
1399: 1052
1500: 1053
999999: 531440
这道题主要思路与就是看最高位是否大于或等于4,如果是的话,就把最高位减一,然后把所得的数字作为9进制数转化成10进制,代码如下
在这里插入图片描述

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int main(){
	string str;
	while(cin>>str&&str!="0"){
		int len=str.size();
		int sum=0;
		for(int i=0;i<len;i++){
			int t=str[i]-'0';
			if(t>=4){
				sum+=(pow(9,len-1-i)*(t-1));
			}
			else{
				sum+=(pow(9,len-1-i)*t);
			}
		}
		cout<<str<<": "<<sum<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/dcy19991116/article/details/89472049