【POJ - 1837】Balance(dp及其优化)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/89322468

题干:

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm); 
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

题目大意:

  有一个天平,左侧15的长度,右侧15的长度。上面有C个地方可以放砝码,分别告诉你x坐标(天平轴是坐标零点)。然后告诉你有G个砝码,问你可以使得天平平衡的总方案数。

解题报告:

  dp[i][j]代表放置了前i个砝码,右侧比左侧重量多j,的方案数。然后xjb递推就行了。本来是“人人为我型”T了,然后改成“我为人人型”并且加了点优化才A。。(好像是因为上界开太大了所以T了⑧)

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
typedef pair<int,int> PII;
const int MAX = 2e5 + 5;
ll n;
int a[MAX],b[MAX];
int dp[33][MAX];//代表右边减左边的 
const int zero = 1e5;
int main()
{
	int c,g;
	while(~scanf("%d%d",&c,&g)) {
		memset(dp,0,sizeof dp);
		dp[0][zero] = 1;
		for(int i = 1; i<=c; i++) scanf("%d",a+i);
		for(int i = 1; i<=g; i++) scanf("%d",b+i);
		for(int i = 1; i<=g; i++) {
			for(int j = 0; j<MAX; j++) {
				if(dp[i-1][j] == 0) continue;
				for(int k = 1; k<=c; k++) {
					if(j+a[k]*b[i] >= 0 && j+a[k]*b[i] < MAX) dp[i][j+a[k]*b[i]] += dp[i-1][j];			
				}
			}
		}
		printf("%d\n",dp[g][zero]);
	}
	return 0 ;
}

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/89322468
今日推荐