2002计算球体积 c++

Problem Description
根据输入的半径值,计算球的体积。
Input
输入数据有多组,每组占一行,每行包括一个实数,表示球的半径。
Output
输出对应的球的体积,对于每组输入数据,输出一行,计算结果保留三位小数。
#define PI 3.1415927
Sample Input
1
1.5
Sample Output
4.189
14.137

#include<iostream>
#include<iomanip>
using namespace std;
#define PI 3.1415927
int main() {
	double r;
	double V = 0;
	while (cin >> r) {
		V = PI * r * r * r * 4 / 3;
		cout << fixed << setprecision(3) << V << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41274723/article/details/89499878