H - A Simple Triangle NBUT - 1226

In this problem you need to make a triangle ,just like the sample out. The element in the ith row and jth column

should be the product(乘积) of i and j.

Input

The first line of input is an integer C which indicate the number of test cases. 
Then C test cases follow.Each test case contains an integer N (1<=N<=20) in a line which mentioned above.

Output

For each test case, print out the triangle. the triangle separated by a blank line. 
If the product is more than 9 (product > 9) you should print a space, or you should print two space.The final number of each line don't need print space. 

Sample Input

3
5
6
7

Sample Output

1  2  3  4  5
2  4  6  8
3  6  9
4  8
5

1  2  3  4  5  6
2  4  6  8  10
3  6  9  12
4  8  12
5  10
6

1  2  3  4  5  6  7
2  4  6  8  10 12
3  6  9  12 15
4  8  12 16
5  10 15
6  12
7

Hint

在这个问题中,你需要做一个三角形,就像样本一样。第i行和第j列中的元素

应该是i和j的积。

输入

输入的第一行是一个整数C,表示测试用例的数量。

然后是C测试用例,每个测试用例在上面提到的一行中包含一个整数n(1<=n<=20)。

产量

对于每个测试用例,打印出三角形。用空行分隔的三角形。

如果产品大于9(产品大于9),则应打印一个空格,或打印两个空格。每行的最后一个数字不需要打印空格。

题意:

如果结果大于9在结果后输出一个空格,否则输出两个,翻译的锅。。。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int a=n;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=a;j++)
            {
                printf("%d",i*j);
                if(i*j<=9&&j!=a)
                    printf("  ");
                else if(i*j>9&&j!=a)
                    printf(" ");
            }
            a--;
            printf("\n");
        }
        if(t)
            printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43740907/article/details/88899981