HDU 4597 Play Game(记忆化搜索)

Play Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1704    Accepted Submission(s): 1014


Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input
The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤b i≤10000).
 

Output
For each case, output an integer, indicating the most score Alice can get.
 

Sample Input
 
  
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output
 
  
53 105
 

Source
 
记忆化搜索,dp[l][r][l1][r1]表示第一、第二堆的边界内 b可以取到的最大值,因为b是最后取完的点,比较容易判断结束,maxa,maxb表示 a b在当前的范围内取得值
#include <stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
int dp[50][50][50][50];
int a[101];
int b[101];
int suma[1001],sumb[1001];
int dfs(int l,int r,int l1,int r1)
{
	if(dp[l][r][l1][r1]!=-1)
	{
		return dp[l][r][l1][r1];
	}	
	int maxa=0,maxb=0;
	if(l<=r)
	{
		maxa=max(dfs(l+1,r,l1,r1)+a[l],dfs(l,r-1,l1,r1)+a[r]);	
	}
	
	if(l1<=r1)
	{
		maxb=max(dfs(l,r,l1+1,r1)+b[l1],dfs(l,r,l1,r1-1)+b[r1]);	
	}
	dp[l][r][l1][r1]=suma[r]-suma[l-1]+sumb[r1]-sumb[l1-1]-max(maxa,maxb);
	return dp[l][r][l1][r1];
} 
int main(int argc, char *argv[])
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(suma,0,sizeof(suma));
		memset(sumb,0,sizeof(sumb));
		memset(dp,-1,sizeof(dp));	
		int i;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			suma[i]+=suma[i-1]+a[i];
		}
		
		for(i=1;i<=n;i++)
		{
			scanf("%d",&b[i]);
			sumb[i]=sumb[i-1]+b[i];
		}
		dfs(1,n,1,n);
		printf("%d\n",suma[n]+sumb[n]-dp[1][n][1][n]);
		
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/com_ice/article/details/79862994