POJ2385 Apple Catching

A p p l e C a t c h i n g Apple Catching

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16105 Accepted: 7926

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input

  • Line 1: Two space separated integers: T and W

  • Lines 2…T+1: 1 or 2: the tree that will drop an apple each minute.
    Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1
Sample Output

6

一道比较经典的DP题,找到状态转移方程就行了
一开始我以为要用DP[ i ] [ j ] [ k ]来表示时间为i时移动j次在树k下时最多能拿到多少apple
其实第三个维度是不需要的,知道起始点之后根据步数的奇偶性就能判断出在哪棵树下面了,(居然这都没想到)
实际上只要二维就够了,直接表示为 i 时刻移动 j 次最多能拿到多少apple
DP状态转移方程:DP[ i ][ j ] = max(DP[ i-1 ][ j ], DP[ i-1 ][ j-1 ]),当 i 时刻到达的树下这个时候有苹果落下来的话DP[ i ][ j ]++ ,根据奇偶性判断一下就好了,奇数次的话就是到了2号树,偶数就是1号树

二维dp

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
static const int maxn = 1e3+7;
int t,maxx,tree[maxn];
int dp[maxn][40];
void input(){
    scanf("%d %d",&t,&maxx);
    for(int i=1;i<=t;i++)
        scanf("%d",&tree[i]);
}
void solve(){
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=t;i++){
        for(int j=0;j<=i&&j<=maxx;j++){
            if(j==0) dp[i][j] = dp[i-1][j];
            else dp[i][j] = max(dp[i-1][j-1],dp[i-1][j]);
            if(j&1 && tree[i]==2) dp[i][j]++;
            else if(!(j&1) && tree[i]==1) dp[i][j]++;
        }
    }
    printf("%d\n",max(dp[t][maxx],dp[t][maxx-1]));
}
int main(){
    input();
    solve();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_43710979/article/details/88595096