poj1195 Mobile phones-二维 树状数组

版权声明:本文为博主原创文章,转载请标明原博客。 https://blog.csdn.net/sdau_fangshifeng/article/details/87348710

题目链接:

http://poj.org/problem?id=1195

Mobile phones

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 23026   Accepted: 10653

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 


The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

Source

IOI 2001

扫描二维码关注公众号,回复: 6098472 查看本文章

题目大意:

对于S*S二维区间内,初始值是0,

0 S 输入S

1 X Y A 是对坐标(X,Y) 加A

2 L B R T是求(L,B)到(R,T)的矩形区域内的坐标权值的和

3 结束

思路,二维树状数组(模板)

This is the code

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define pppp cout<<endl;
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x3f3f3f3f      //1061109567
#define LL_INF 0x3f3f3f3f3f3f3f3f //4557430888798830399
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int dr[]={0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]={-1, 1, 0, 0, -1, 1, -1, 1};
inline int read()//输入外挂
{
    int ret=0, flag=0;
    char ch;
    if((ch=getchar())=='-')
        flag=1;
    else if(ch>='0'&&ch<='9')
        ret = ch - '0';
    while((ch=getchar())>='0'&&ch<='9')
        ret=ret*10+(ch-'0');
    return flag ? -ret : ret;
}
const int maxn=1100;
int c[maxn][maxn];//树状数组使用
int s;

int lowbit(int x)
{
    return x&-x;
}

int getSum(int x,int y)
{
    int ret=0;
    for(int i=x;i>=1;i-=lowbit(i))
        for(int j=y;j>=1;j-=lowbit(j))
            ret+=c[i][j];
    return ret;
}

void add(int x,int y,int d)
{
    for(int i=x;i<=s;i+=lowbit(i))
        for(int j=y;j<=s;j+=lowbit(j))
            c[i][j]+=d;
}
int main()
{
    //freopen("D:\\chnegxubianji\\inORout\\in.txt", "r", stdin);
    //freopen("D:\\chnegxubianji\\inORout\\out.txt", "w", stdout);
    int tem;
    while(~scanf("%d",&tem))
    {
        if(tem==3)
            continue;
        switch(tem)
        {
        case 0:
            {
                scanf("%d",&s);
                memset(c,0,sizeof(c));
                break;
            }
        case 1:
            {
                int a,b,w;
                scanf("%d%d%d",&a,&b,&w);
                add(a+1,b+1,w);
                break;
            }
        case 2:
            {
                int a,b,c,d;
                scanf("%d%d%d%d",&a,&b,&c,&d);
                printf("%d\n",getSum(c+1,d+1)-getSum(a,d+1)-getSum(c+1,b)+getSum(a,b));
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdau_fangshifeng/article/details/87348710
今日推荐