Floating-Point Hazard 【数学】

版权声明:本文为博主原创文章,转载请注明出处( • ̀ω•́ )✧ https://blog.csdn.net/wangws_sb/article/details/89676999

题目链接:http://icpc.upc.edu.cn/problem.php?cid=1740&pid=9

题目描述

Given the value of low, high you will have to find the value of the following expression:

If you try to find the value of the above expression in a straightforward way, the answer may be incorrect due to precision error.

输入
The input file contains at most 2000 lines of inputs. Each line contains two integers which denote the value of low, high (1 ≤ low ≤ high ≤ 2000000000 and high-low ≤ 10000). Input is terminated by a line containing two zeroes. This line should not be processed.

输出
For each line of input produce one line of output. This line should contain the value of the expression above in exponential format. The mantissa part should have one digit before the decimal point and be rounded to five digits after the decimal point. To be more specific the output should be of the form d.dddddE-ddd, here d means a decimal digit and E means power of 10. Look at the output for sample input for details. Your output should follow the same pattern as shown below.

样例输入
复制样例数据
1 100
10000 20000
0 0
样例输出
3.83346E-015
5.60041E-015

解题思路

根据导数定义 设 f ( x ) = x 3 f(x)=\sqrt[3]{x} ,那么根据导数定义对 f ( x ) f(x) 求导可得 x + 1 0 15 3 x 3 Δ x = 1 3 x 2 3 \frac{\sqrt[3]{x+10^{-15}}-\sqrt[3]{x}}{\Delta x}=\frac{1}{3}x^{\frac{-2}{3}}
x + 1 0 15 3 x 3 = 1 3 x 2 3 × Δ x \sqrt[3]{x+10^{-15}}-\sqrt[3]{x}=\frac{1}{3}x^{\frac{-2}{3}}\times{\Delta x} Δ x = 1 0 15 {\Delta x}=10^{-15} ,然后根据求公式 1 3 x 2 3 × Δ x \frac{1}{3}x^{\frac{-2}{3}}\times{\Delta x} 在区间 [ x , y ] [x,y] 上的和。

AC代码

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <map>
#include <set>
using namespace std;
#define io ios::sync_with_stdio(0),cin.tie(0)
#define ms(arr) memset(arr,0,sizeof(arr))
#define mc(a,b) memcpy(a,b,sizeof(b))
#define inf 0x3f3f3f
#define fin freopen("in.txt", "r", stdin)
#define fout freopen("out.txt", "w", stdout)
typedef long long ll;
typedef unsigned long long ULL;
const int mod=1e9+7;
const int N=1e5+7;

int main()
{
//    fin;
    int n,m;
    while(scanf("%d%d",&n,&m)&&n+m)
    {
        double ans=0;
        for(int i=n; i<=m; i++)
        {
            ans+=(1.0/3.0)*pow(double(i),(-2.0/3.0));
        }
        int cnt=0;
        while(ans<1)
        {
            ans*=10.0;
            cnt--;
        }
        while(ans>10)
        {
            ans/=10.0;
            cnt++;
        }
        printf("%.5fE-%03d\n",ans,15-cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/89676999