A Walk Through the Forest HDU - 1142 最短路+记忆化搜索DFS

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647 

Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output

2
4

题意:假设 A 和 B 是相连的,当前在 A 处,如果 A 到终点的距离大于 B 到终点的距离,则可以从 A 通往 B 处,问满足这种的条件的从1到2的路径条数。

思路:先从终点2跑一遍最短路,dis数组里存的是第i个点到终点2的最短距离,然后从起点1开始进行dfs,向下搜索的条件是dis[fa]>dis[now],记得用记忆化搜索,不然会超时。

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000009;
int n,m,dis[1009],head[1009],book[1009],cnt;
struct node{
	int id;
	int cost;
	int next;
	node(){}
	node(int id,int cost):id(id),cost(cost){}
	friend bool operator < (node x,node y)
	{
		return x.cost>y.cost;
	}
}side[maxn];
void init()
{
	memset(dis,0x3f3f3f3f,sizeof(dis));
	memset(head,-1,sizeof(head));
	memset(book,0,sizeof(book));
	cnt=0;
}
void add(int x,int y,int d)
{
	side[cnt].id=y;
	side[cnt].cost=d;
	side[cnt].next=head[x];
	head[x]=cnt++;
}
void dij(int sx)
{
	priority_queue<node> q;
	dis[sx]=0;
	q.push(node(sx,0));
	while(q.size())
	{
		node now=q.top();
		q.pop();
		if(book[now.id]) continue;
		book[now.id]=1;
		for(int i=head[now.id];i!=-1;i=side[i].next)
		{
			int y=side[i].id;
			if(dis[y]>dis[now.id]+side[i].cost)
			{
				dis[y]=dis[now.id]+side[i].cost;
				q.push(node(y,dis[y]));
			}
		}
	}
}
int dfs(int x,int fa)
{
	if(x==2) return 1;
	if(book[x]) return book[x];
	for(int i=head[x];i!=-1;i=side[i].next)
	{
		int y=side[i].id;
		if(y==fa) continue;
		if(dis[y]<dis[x])
			book[x]+=dfs(y,x);
	}
	return book[x];
}
int main()
{
	while(~scanf("%d",&n)&&n)
	{
		scanf("%d",&m);
		init();
		for(int i=1;i<=m;i++)
		{
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			add(x,y,z);
			add(y,x,z);
		}
		dij(2);	
		memset(book,0,sizeof(book));	
		printf("%d\n",dfs(1,-1));
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/why932346109/article/details/88943640